Jun 3, 2008

Lemon 1.5: Comparing LEGO® models


Today I've published version 1.5 of Lemon on my web site for Download.
Lemon is a Java-based application with a graphical user interface that allows for comparing two LEGO® models that are stored in LDraw or LDD format; the common parts are listed as well as the ones that are contained in one of the models only.
It's also possible to check a model against the NXT Retail Kit or (new to 1.5) against the NXT Education Kit - comes in handy if you want to know whether a model can be built with one of these kits.
Moreover, the new version supports multi module models now and contains numerous bugfixes.

Give it a try, please, and provide feedback and proposals.

Addendum: If someone is encountering problems with Lemon, please do not hesitate to contact me via the contact page on my web site.

3 comments:

Hunter Chiou said...

Thank you for the comparison of LEGO NXT Edu Kit.
It's really helpful especially the one who only has 9797.
Now I can know what parts I need.
Thank you again!

David Levy said...

Matthias,
Thank you for this.

I did have a problem running the installer. ( with an existing java 5 runtime)

Do I need windows env vars defined in addition to JAVA_HOME , JDK_HOME?

Here is the error:
An error occurred while launching/running the application.

Title: Lemon
Vendor: Matthias Paul Scholz
Category: Unexpected Error

Unexpected exception: java.lang.Exception
at com.sun.javaws.Launcher.continueLaunch(Unknown Source)
at com.sun.javaws.Launcher.handleApplicationDesc(Unknown Source)
at com.sun.javaws.Launcher.handleLaunchFile(Unknown Source)
at com.sun.javaws.Launcher.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

David

Matthias Paul Scholz said...

David,

well, an "unexpected error" is hard to track...
I don't know of any other environment variable required than JAVA_HOME.
Yet, there are rumours of issues with Java Web Start when the Java versions the app has been packed with (I used Java 6) and the client are not the same major ones (though nominally one can specify the Java version in the jnlp file and I did so for Lemon with Java 5).

Would it be an option for you to try it with Java 6 (there's a "Do I have the latest Version of Java?" utility on www.java.com)?

Related Posts Plugin for WordPress, Blogger...